Installation bleibt hängen

Der Support von InstallPro Express wurde eingestellt. Dieses Forum steht nur noch zu Informationszwecken bereit.

Moderator: Support

jatag
Newbie
Newbie
Beiträge: 11
Registriert: Di 14. Mär 2006, 20:38

Installation bleibt hängen

Beitrag von jatag »

Hallo,

ich habe mich gerade neu angemeldet, da ich den Install Pro Express 1.7z heruntergeladen habe und ihn sehr gut finde, da man verschiedene Einstellungen vornehmen kann. Sehr gut finde ich z. B., dass man seine eigenen Bilder einbauen kann. Leider habe ich bei der Installation den gleichen Fehler, wie bereits weiter unten beschrieben, auch gehabt: RICHTX32.ocx kann nicht registriert werden oder so ähnlich. Nachdem ich diese Datei mit regsvr32.exe erneut registiert habe, wurde InstallPro anstandslos installiert. Nun habe ich mein erstes Installationsprogramm fertig gestellt und wollte dies auf einem anderen Rechner testweise installieren. Das Installationsprogramm startet, es erscheint der Wizzard, danach auch noch die von mir angegebene Lizenzdatei, doch wenn ich dann auf weiter klicke, passiert nichts mehr. Ich habe daraufhin die setup.exe Datei auf einem weiteren Rechner versucht zu installieren, aber das gleiche Problem. Nach der Anzeige meiner Lizenzdatei geht es nicht mehr weiter. VB6-Runtime habe ich auch auf dem Rechner installiert, auf dem sich das Programm InstallPro befindet. Alle Rechner arbeiten mit WindowsXP SP2.
Kann mir jemand weiter helfen, da ich dieses Programm echt gut finde und auch damit weiter arbeiten möchte, nachdem ich schon das ein oder andere Installationsprogramm ausprobiert habe. Auch der Verpackungsassistent von VB6 ist nicht gerade komfortabel und man kann dort auch kaum eigene Dateien einbauen, die das Aussehen verschönern sollen.

Gruß Jürgen

Benutzeravatar
Alex
Support
Support
Beiträge: 2669
Registriert: Mi 29. Mär 2006, 18:11

Installation bleibt hängen

Beitrag von Alex »

Hallo,

kommt denn irgendeine Fehlermeldung, nachdem Sie auf "Weiter" geklickt haben? Siehst Du denn noch die Lizenz?
RICHTX32.ocx kann nicht registriert werden oder so ähnlich.
Das Problem tritt komischerweise beim 2. Aufruf nicht mehr auf. Ich weiß selbst nicht, woran es genau liegt.
Alexander Seeliger
{Support}

jatag
Newbie
Newbie
Beiträge: 11
Registriert: Di 14. Mär 2006, 20:38

Installation bleibt hängen

Beitrag von jatag »

Das Bild bleibt nur stehen. Keine Fehlermeldung. Ich kann auch mit zurück zum vorherigen Bildschirm des Wizard gehen und wieder weiter bis zum Lizenzeintrag, doch dann geht es nicht mehr weiter. Ich habe auch bereits alles deinstalliert, dann neu installiert und auch ein neues Setup erstellt, aber immer das gleiche. Kann es etwas mit den OCX-Dateien zu tun haben, da ich festgestellt habe, dass die Dateien comdlg32.ocx, mscomctl.ocx (im Hauptverzeichnis von InstallPro) und mscomct2.ocx (im Templateverzeichnis) vorhanden sind, ich diese aber auch in meinem Programm nutze und in die Installroutine über Dateien eingebunden habe.

Gruß Jürgen

Benutzeravatar
Alex
Support
Support
Beiträge: 2669
Registriert: Mi 29. Mär 2006, 18:11

Installation bleibt hängen

Beitrag von Alex »

Das Bild bleibt nur stehen. Keine Fehlermeldung.
Also das ist schon sehr merkwürdig. Hast du mal versucht den Lizenzvertrag wegzulassen? Funktioniert dann wenigstens die Installation?
Für mich ist das Problem leider in keinster Weise nachvollziehbar, da keine wichtige Aktion etc. an dieser Stelle durchgeführt wird.
Kann es etwas mit den OCX-Dateien zu tun haben
Eigentlich nicht, da die OCX-Dateien ja auch von mehreren Programmen verwendet werden können.
Alexander Seeliger
{Support}

jatag
Newbie
Newbie
Beiträge: 11
Registriert: Di 14. Mär 2006, 20:38

Installation bleibt hängen

Beitrag von jatag »

Ich habe jetzt den Lizenzvertrag weggelassen, aber jetzt erscheint nur noch der Hauptbildschirm vom Wizard und wenn ich auf weiter klicke, passiert nichts. Also eigentlich wie gehabt.

jatag
Newbie
Newbie
Beiträge: 11
Registriert: Di 14. Mär 2006, 20:38

Installation bleibt hängen

Beitrag von jatag »

Ich vermute mittlerweile, da ich bereits die OCX-Dateien mscomctl.ocx, comdlg32.ocx und mscomct2.ocx mit regsvr32.exe nochmals registriert habe, jedoch ohne Erfolg, dass eventuell noch weitere OCX- oder DLL-Dateien nicht registriert sind. Kannst Du mir sagen, welche OCX- und DLL-Dateien Dein Programm verwendet ?

jatag
Newbie
Newbie
Beiträge: 11
Registriert: Di 14. Mär 2006, 20:38

Installation bleibt hängen

Beitrag von jatag »

Ich hab jetzt alles nochmals probiert. Alle OCX-Dateien neu registriert. Lizenzvertrag weggelassen usw., aber kein Erfolg. Ich habe jetzt auf meinem Hauptrechner mal versucht, die Installation durchzuführen und siehe da, es funktioniert. Dabei fiel mir ein, dass ich auch auf dem anderen PC bereits einmal die Installation ausführen konnte, dann habe ich das Programm deinstalliert und seit dieser Zeit funktioniert keine Neuinstallation mehr. Auf meinem Laptop habe ich aber noch nie die Installation meines Programmes durchgeführt, dort habe ich auch versucht, mein Programm zu installieren, aber wie auf dem anderen Rechner, der Wizard bleibt hängen.

Benutzeravatar
Alex
Support
Support
Beiträge: 2669
Registriert: Mi 29. Mär 2006, 18:11

Installation bleibt hängen

Beitrag von Alex »

Also, wie gesagt: sehr merkwürdig.

Nun ja, hast du mal das Kontrollkästchen "Vollständige Runtime hinzufügen" (zu finden unter Allgemeine Informationen -> Weitere Einstellungen) aktiviert?
Alexander Seeliger
{Support}

jatag
Newbie
Newbie
Beiträge: 11
Registriert: Di 14. Mär 2006, 20:38

Installation bleibt hängen

Beitrag von jatag »

Habe ich aktiviert.

Benutzeravatar
Alex
Support
Support
Beiträge: 2669
Registriert: Mi 29. Mär 2006, 18:11

Installation bleibt hängen

Beitrag von Alex »

Ich werde mir die entsprechenden Codestellen nochmal angucken und schauen, was das Problem sein könnte. Das kann allerdings etwas dauern.
Alexander Seeliger
{Support}

jatag
Newbie
Newbie
Beiträge: 11
Registriert: Di 14. Mär 2006, 20:38

Installation bleibt hängen

Beitrag von jatag »

Da mir Dein Programm sehr gut gefällt, habe ich weiter experimentiert. Ich habe mein Programm mit dem VB6-Installationsprogramm erstellt und dann installiert. Es läuft. Dann hab ich das mit Deinem Programm erstelle Setup gestartet und siehe da, es bleibt nicht mehr hängen und installiert mein Programm. Doch leider funkioniert es nicht. Es kommt die im anhängenden Bild angezeigte Fehlermeldung. Aber es wird noch interessanter. Danach funktioniert Dein Setup nicht mehr, also es bleibt wieder stehen. Das Setup geht also nur einmal, dann kein zweites Mal mehr. Ich hoffe, ich habe mich verständlich ausgedrückt.
Das mit dem VB6-Installationsprogramm im parallel Ordner erstellte Programm geht nach der Installation mit Deinem Programm dann auch nicht mehr und zeigt den gleichen Fehler an. Installiere ich dann wieder das Setup von VB6, wohl gemerkt in einem anderen Ordner, funktioniert sowohl dieses Programm als auch das mit Deinem Setup im anderen Ordner erstellte. Es muss also doch an einer DLL-Datei in Deinem Programm liegen.

Ist Dein Programm eigentlich auch mit VB6 erstellt ?

Benutzeravatar
Alex
Support
Support
Beiträge: 2669
Registriert: Mi 29. Mär 2006, 18:11

Installation bleibt hängen

Beitrag von Alex »

Also scheinbar liegt es an einer nicht registrierten Bibliothek. Hochstwahrscheinlich deregistriert der VB6 Installer die gesamten DLLs wieder, sobald das Programm wieder entfernt wird.

Normalerweise tritt solch ein Registrierungsfehler nur auf, wenn falsche Registrierungseinträge in der Registry existieren. Das Problem drüfte sich aber einfach beheben.

Registrierungseinträge bereinigen

1. Als erstes solltest du die Dateien msvbvm60.dll, VB6DE.DLL, RICHTX32.OCX, MSCOMCT2.OCX in das System32 Verzeichnis von Windows kopieren (nur neuere Dateiversionen ersetzen, falls bereits Dateien existieren) C:WindowsSystem32.

2. Dann solltest du alle eben kopierten Dateien manuell registrieren mit regsvr32. Damit werden die Dateien wieder richtig registriert und sind wieder von verschiedenen Programmen abrufbar.

3. Ich empfehle dir, die Registry nun mit einem RegCleaner zu bereinigen, damit fehlerhafte Registrierungen von Bibliotheken gelöscht werden. Das kann auch zu einem schnelleren und stabileren Windows führen.

Nun sollte auch InstallPro korrekt funktionieren. Normalerweise braucht InstallPro Express diese Dateien nicht als registrierte Bibliotheken, da Sie ja mitgeliefert werden. Allerdings sucht die Vb6-Runtime erst nach registrierten Dateien und dann erst nach den Dateien, die im gleichen Ordner, wie die Anwendung, liegen.

Ich hoffe, dass durch die Bibliothekenregistrierungsbereinigung alles wieder normal funktioniert.
Alexander Seeliger
{Support}

jatag
Newbie
Newbie
Beiträge: 11
Registriert: Di 14. Mär 2006, 20:38

Installation bleibt hängen

Beitrag von jatag »

Punkt 1-3 habe ich schon zuvor durchgeführt, brachte jedoch keinen Erfolg. Ich habe auch nicht das mit VB6 erstellte Programm deinstalliert, so daß eine Deregistrierung der DLL- oder OCX-Dateien ausscheidet. Im Übrigen läuft Dein Installer auf meinem Laptop, der absolut frei und sauber ist, auch nur bis zum Text der Lizenz und bleibt dann stehen. Also nochmals: Wenn ich mit dem VB-Installer über meine Programmversion (ohne Deinstallation) drüber kopiere, läuft sowohl mein Programm als auch Dein Installer, aber Dein Installer nur einmal und dann kommt die Fehlermeldung. SORRY !!!

Benutzeravatar
Alex
Support
Support
Beiträge: 2669
Registriert: Mi 29. Mär 2006, 18:11

Installation bleibt hängen

Beitrag von Alex »

Irgendwie verstehe ich die Welt nicht mehr.

Ich habe das ganze InstallPro auf einem neu aufgesetzten Windows ausgetestet und es hat alles funktioniert. Leider kann ich das Problem mit dem einmal aufrufen überhaupt nicht nachvollziehen. Weiterhin ist es mir nicht gelungen den Fehler nach dem Lizenzdialog ausfindig zu machen, da genau an dieser Stelle weder neue Steuerelemente nach möglicherweise fehlerhafter Code ausgeführt wird.

Leider scheinst du der einzige zu sein, bei dem dieser Fehler auftritt. Es kann definitiv kein Programmfehler sein. Es muss ein Bibliothekenfehler sein. :-/
Alexander Seeliger
{Support}

jatag
Newbie
Newbie
Beiträge: 11
Registriert: Di 14. Mär 2006, 20:38

Installation bleibt hängen

Beitrag von jatag »

Ich verstehe die Welt auch nicht mehr.

Trotzdem möchte ich Dir für Deine Bemühungen danken. Ich werde noch mal versuchen, einem Bekannten Dein Installationsprogramm zum testen zu geben. Wenn es dort läuft, dann liegt es definitiv an meinen drei Rechnern, nur komisch, dass es bei allen dreien nicht funktioniert. Aber egal, werd ich sehen.

Allen anderen, bei denen das Installations-Programm läuft bzw. die es einsetzen wollen, kann ich es nur wärmstens empfehlen, da es sehr einfach gehalten ist und doch eine Menge bietet, um ein eigenes, individuelles Setup zu erstellen.

Gruß Jürgen

Gesperrt