Dateien nach Install verschwunden

Der Support von InstallPro Express wurde eingestellt. Dieses Forum steht nur noch zu Informationszwecken bereit.

Moderator: Support

Gesperrt
wastl
Jr. Member
Jr. Member
Beiträge: 27
Registriert: Mo 19. Sep 2005, 18:58

Dateien nach Install verschwunden

Beitrag von wastl »

Hallo,

hab nun ein kleines Problem.

Nach dem ich ein Setup erstellt habe und dieses getestet habe wahren bis auf die uninst.exe und die .ini nix mehr im Verzeichniss.

Nun zum Umfeld:

Habe einen Ordner erstellt.
In diesem befinden sich ca. 600 kleine .gif Dateien. :vogel:
Sonst nichts, keine .exe oder andere Dateien.

Habe im Install Express alle .gif Dateien eingetragen.
Habe als verknüpfung nur die durch den Inst.Express erstellte uninst.exe eingetragen
Welche nach dem ausführen des setup"s auch korekt im Startmenü - Programme vorhanden ist.

Nur hat leider das Installations Verzeichniss nur rund 60kb und nicht ca. 2mb wie es sein müßte.
Kein einziges .gif Bild, nicht"s. :#:
Obwohl, so hat es zumindest den anschein alles mitinstalliert wird.
Das Setup dauert entsprechend lange.
wastl grüßt und Dankt.

Benutzeravatar
Alex
Support
Support
Beiträge: 2655
Registriert: Mi 29. Mär 2006, 18:11

Dateien nach Install verschwunden

Beitrag von Alex »

Hallo,

eventuell hast du den falschen Ordnerpath oder die falsche Ordnervariable angegeben.

Wird denn die Installation richtig erstellt, also ohne Fehler? Und sind die Setupdateien korrekt?
Alexander Seeliger
{Support}

wastl
Jr. Member
Jr. Member
Beiträge: 27
Registriert: Mo 19. Sep 2005, 18:58

Dateien nach Install verschwunden

Beitrag von wastl »

Jo Hallo,

das Setup wird ohne Fehlermeldung erstellt.

Die einzelnen Dateien scheinen auch i.o. zu sein, die 01.cab hat 74kb und die 02.cab hat rund 1,7mb was auch hinkommen dürfte.

Auch das ausführen des Setup"s verläuft normal, der Installations Vortschritt Balken läuft Ordentlich bis zum Schluß, was zwar etwas Zeit in Anspruch nimmt aber bei der masse an Dateien nur Normal sein dürfte.

Wie gesagt es scheint alles völlig Normal zu sein nur das eben dan im Install-Verzeichniss nur die Uninst.exe und die Zugehörige .ini drin sind sonst nix.

Zitat ein:

eventuell hast du den falschen Ordnerpath oder die falsche Ordnervariable angegeben.

Zitat aus: :)

Wie meinste den das.
Ich hab da garnix angegeben, nur wohin er alles Installieren soll.
z.B. X:ProgrammeProgrammName

Mehr nicht.

Schon sehr Misteriös ist das alles, bisher hat immer alles so gut geklappt.
wastl grüßt und Dankt.

Benutzeravatar
Alex
Support
Support
Beiträge: 2655
Registriert: Mi 29. Mär 2006, 18:11

Dateien nach Install verschwunden

Beitrag von Alex »

Hmm. Das ist sehr merkwürdig. Eventuell hilft es mir, wenn du mir mal das Installationsskript zusenden könntest.

E-Mail: alexosoft [at] gmx [punkt] de
Zitat ein:

eventuell hast du den falschen Ordnerpath oder die falsche Ordnervariable angegeben.

Zitat aus: :)

Wie meinste den das.
Ich meinte die Verzeichnisvariable, die du beim hinzufügen der Dateien angegeben hat, also zum Beispiel: #InstallPath#... etc.
Alexander Seeliger
{Support}

wastl
Jr. Member
Jr. Member
Beiträge: 27
Registriert: Mo 19. Sep 2005, 18:58

Dateien nach Install verschwunden

Beitrag von wastl »

Abend,

werde Dir gleich eine eMail schicken mit dem Script als .txt Datei und einige Desktop Bilder damit Du das sehen kannst was ich meine.
wastl grüßt und Dankt.

Benutzeravatar
Alex
Support
Support
Beiträge: 2655
Registriert: Mi 29. Mär 2006, 18:11

Dateien nach Install verschwunden

Beitrag von Alex »

Gutern Morgen,

also ich glaube zu wissen, woran der Fehler liegt. Ich schätze mal, dass InstallPro nicht mit Dateinamen mit Klammern klar kommt.

Ich werde das aber erstmal selbt prüfen, und kann dir dann sagen, ob es daran liegt.
Alexander Seeliger
{Support}

wastl
Jr. Member
Jr. Member
Beiträge: 27
Registriert: Mo 19. Sep 2005, 18:58

Dateien nach Install verschwunden

Beitrag von wastl »

Hallo,
von mir auch noch einen schönen guten Morgen.

Das währe ja schon mal toll wenn es nur daran liegen sollte.

Kann mann sowas noch Programm Technisch bereinigen oder muß ich mir ein anderes Zählsystem einfallen lassen.


Komisch ist aber das ich das Setup ja Ordentlich erstellen kann, ohne das der InstallPro rummeckert.


Es scheint ja erst Probleme zu geben bei der Ausführung ( Installation ) des Setup"s.
wastl grüßt und Dankt.

Benutzeravatar
Alex
Support
Support
Beiträge: 2655
Registriert: Mi 29. Mär 2006, 18:11

Dateien nach Install verschwunden

Beitrag von Alex »

Es scheint ja erst Probleme zu geben bei der Ausführung ( Installation ) des Setup"s.
Und genau das werde ich nochmal überprüfen. ;-)
Alexander Seeliger
{Support}

wastl
Jr. Member
Jr. Member
Beiträge: 27
Registriert: Mo 19. Sep 2005, 18:58

Dateien nach Install verschwunden

Beitrag von wastl »

Hallo,

hab es gerade bei mir nochmal versucht, und zwar habe ich sämtliche .gif Dateien fortlaufend umnummeriert z.B. xxx 2.gif und xxx 3.gif.

Hatte aber das selbe endergebniss.
Also an den Klammern kanns somit nicht gelegen haben.
wastl grüßt und Dankt.

wastl
Jr. Member
Jr. Member
Beiträge: 27
Registriert: Mo 19. Sep 2005, 18:58

Dateien nach Install verschwunden

Beitrag von wastl »

So nun hab ich"s,

es liegt an den Leerstellen im Datei Namen.

Hab nun nochmal alles Umbenannt und die Leerzeichen im Namen entfernen lassen, jetzt heißen sie XXX101.gif und XXX102.gif u.s.w. und damit klappt dan die Installation einwandfrei.


Frage:

Kann man das Leerstellen Problem lösen oder ist dies Kompatibilitäts bedingt.
wastl grüßt und Dankt.

Benutzeravatar
Alex
Support
Support
Beiträge: 2655
Registriert: Mi 29. Mär 2006, 18:11

Dateien nach Install verschwunden

Beitrag von Alex »

Also ich hab das selbst nochmal getestet und bin auch zu diesem Fehler gekommen. Zur Zeit lässt sich das Problem noch nicht lösen. Werde aber eine andere Lösung suchen.
Alexander Seeliger
{Support}

wastl
Jr. Member
Jr. Member
Beiträge: 27
Registriert: Mo 19. Sep 2005, 18:58

Dateien nach Install verschwunden

Beitrag von wastl »

Hallo,


jo DANKE.

Hoffe Du findest eine Lösung.


Es tauchen doch immer wieder Probleme auf, da Denkt man das das Programm nun gut läuft und dan findet man wieder etwas.

Wie siehts den mit den Anderen sachen aus die Du noch korigieren wolltest.
wastl grüßt und Dankt.

Benutzeravatar
Alex
Support
Support
Beiträge: 2655
Registriert: Mi 29. Mär 2006, 18:11

Dateien nach Install verschwunden

Beitrag von Alex »

[quote="wastl"]
Wie siehts den mit den Anderen sachen aus die Du noch korigieren wolltest.
[/quote]
Ich kann mit großer Wahrscheinlichkeit sagen, dass diese Verbesserungen in die nächste Releaseversion eingebaut werden:
-> Neustart-Option beim Uninstaller
-> Meldung beim Uninstaller, dass eventuell noch der leere Ordner bestehen bleibt
-> (evtl.) Problem mit Dateinamen mit Leerzeichen gelöst
Alexander Seeliger
{Support}

crunchyrocks
Newbie
Newbie
Beiträge: 3
Registriert: Mi 18. Feb 2009, 06:11

Re: Dateien nach Install verschwunden

Beitrag von crunchyrocks »

Der Installations Vortschritt Balken läuft Ordentlich bis zum Schluß. Was zwar etwas Zeit in Anspruch nimmt aber bei der masse an Dateien nur Normal sein dürfte.








___________________________
Computer Teile

Gesperrt